GHSA-33rh-5hvf-5jjpmedium5.3
ZF-Commons ZfcUser Vulnerable to XSS in Login Redirect
The advisory, in context
Cross-site scripting (XSS) vulnerability in user/login.phtml in ZF-Commons ZfcUser before 1.2.2 allows remote attackers to inject arbitrary web script or HTML via the redirect parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zf-commons/zfc-user Packagist
Ecosystem versions
Earlier releases before 1.2.2
Fixed in 1.2.2
10 explicitly affected versions
0.0.1, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.2.0, 1.0.0, 1.1.0, 1.2.0, 1.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.0.1",
"0.1.0",
"0.1.1",
"0.1.2",
"0.1.3",
"0.2.0",
"1.0.0",
"1.1.0",
"1.2.0",
"1.2.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1039
- https://github.com/ZF-Commons/ZfcUser/issues/550
- https://github.com/ZF-Commons/ZfcUser/commit/baf0e460
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zf-commons/zfc-user/CVE-2015-1039.yaml
- https://github.com/ZF-Commons/ZfcUser
- https://web.archive.org/web/20150202091028/http://www.securityfocus.com/bid/71931
- http://www.openwall.com/lists/oss-security/2015/01/11/4