GHSA-2xwq-h7r9-6w27medium4.6
Cross-site Scripting in kimai2
The advisory, in context
Cross site request forgery vulnerability is present in delete functionality of doctor feature. This vulnerability is capable of deleting system logs
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
kevinpapst/kimai2 Packagist
Ecosystem versions
Earlier releases before 1.16
Fixed in 1.16
44 explicitly affected versions
0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.6.1, 0.7, 0.8, 0.8.1, 0.9, 1.0, 1.0.1, 1.1, 1.10, 1.10.1, 1.10.2, 1.11, 1.11.1, 1.12, 1.13, 1.14, 1.14.1, 1.14.2, 1.14.3, 1.15, 1.15.1, 1.15.2, 1.15.3, 1.15.4, 1.15.5, 1.15.6, 1.2, 1.3, 1.4, 1.4.1, 1.4.2, 1.5, 1.6, 1.6.1, 1.6.2, 1.7, 1.8, 1.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1",
"0.2",
"0.3",
"0.4",
"0.5",
"0.6",
"0.6.1",
"0.7",
"0.8",
"0.8.1",
"0.9",
"1.0",
"1.0.1",
"1.1",
"1.10",
"1.10.1",
"1.10.2",
"1.11",
"1.11.1",
"1.12",
"1.13",
"1.14",
"1.14.1",
"1.14.2",
"1.14.3",
"1.15",
"1.15.1",
"1.15.2",
"1.15.3",
"1.15.4",
"1.15.5",
"1.15.6",
"1.2",
"1.3",
"1.4",
"1.4.1",
"1.4.2",
"1.5",
"1.6",
"1.6.1",
"1.6.2",
"1.7",
"1.8",
"1.9"
]
}