GHSA-2wxv-3g4v-p76pmedium
phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence
The advisory, in context
Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpsysinfo/phpsysinfo Packagist
Ecosystem versions
Earlier releases before 3.2.5
Fixed in 3.2.5
10 explicitly affected versions
v3.1.13, v3.1.14, v3.1.15, v3.1.16, v3.1.17, v3.2.0, v3.2.1, v3.2.2, v3.2.3, v3.2.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.1.13",
"v3.1.14",
"v3.1.15",
"v3.1.16",
"v3.1.17",
"v3.2.0",
"v3.2.1",
"v3.2.2",
"v3.2.3",
"v3.2.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2006-3360
- https://github.com/phpsysinfo/phpsysinfo/issues/107
- https://github.com/phpsysinfo/phpsysinfo/issues/368#issuecomment-1380842745
- https://github.com/phpsysinfo/phpsysinfo/commit/60b5bbb5d1cc17f44050e99a3e746f55a4fd4e18
- https://exchange.xforce.ibmcloud.com/vulnerabilities/27527
- https://github.com/phpsysinfo/phpsysinfo