eZ Publish Legacy Cross-site Scripting (XSS) in 'disabled module' error template
The advisory, in context
This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy via the LegacyBridge.
Installations where all modules are disabled may be vulnerable to XSS injection in the module name. This is a rare configuration, but we still recommend installing the update, which adds the necessary input washing.
To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2018.9.0 before 2018.9.1.2
Fixed in 2018.9.1.2
3 explicitly affected versions
v2018.09.0, v2018.09.1, v2018.09.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2018.9.0"
},
{
"fixed": "2018.9.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2018.09.0",
"v2018.09.1",
"v2018.09.1.1"
]
}From 2018.6.0 before 2018.6.1.3
Fixed in 2018.6.1.3
4 explicitly affected versions
v2018.06.0, v2018.06.1, v2018.06.1.1, v2018.06.1.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2018.6.0"
},
{
"fixed": "2018.6.1.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2018.06.0",
"v2018.06.1",
"v2018.06.1.1",
"v2018.06.1.2"
]
}From 2011.0.0 before 2017.12.4.2
Fixed in 2017.12.4.2
43 explicitly affected versions
2013.04.0, v2013.05.0, v2013.06.0, v2013.07.0, v2013.07.1, v2013.07.3, v2013.09.0, v2013.11, v2014.01.0, v2014.01.1, v2014.01.2, v2014.03.1, v2014.03.2, v2014.05.0, v2014.05.1, v2014.05.2, v2014.07.0, v2014.07.1, v2014.07.2, v2014.11.0, v2014.11.1, v2014.11.2, v2015.01.0, v2015.01.1, v2015.01.2, v2015.01.3, v2017.08.0, v2017.08.1, v2017.08.1.1, v2017.10.0, v2017.10.0-RC1, v2017.10.1, v2017.12.0, v2017.12.1, v2017.12.1.1, v2017.12.2, v2017.12.2.1, v2017.12.2.2, v2017.12.3, v2017.12.3.1, v2017.12.3.2, v2017.12.4, v2017.12.4.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2011.0.0"
},
{
"fixed": "2017.12.4.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2013.04.0",
"v2013.05.0",
"v2013.06.0",
"v2013.07.0",
"v2013.07.1",
"v2013.07.3",
"v2013.09.0",
"v2013.11",
"v2014.01.0",
"v2014.01.1",
"v2014.01.2",
"v2014.03.1",
"v2014.03.2",
"v2014.05.0",
"v2014.05.1",
"v2014.05.2",
"v2014.07.0",
"v2014.07.1",
"v2014.07.2",
"v2014.11.0",
"v2014.11.1",
"v2014.11.2",
"v2015.01.0",
"v2015.01.1",
"v2015.01.2",
"v2015.01.3",
"v2017.08.0",
"v2017.08.1",
"v2017.08.1.1",
"v2017.10.0",
"v2017.10.0-RC1",
"v2017.10.1",
"v2017.12.0",
"v2017.12.1",
"v2017.12.1.1",
"v2017.12.2",
"v2017.12.2.1",
"v2017.12.2.2",
"v2017.12.3",
"v2017.12.3.1",
"v2017.12.3.2",
"v2017.12.4",
"v2017.12.4.1"
]
}From 5.4.0 before 5.4.12.2
Fixed in 5.4.12.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.4.0"
},
{
"fixed": "5.4.12.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 5.3.0 before 5.3.12.5
Fixed in 5.3.12.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.3.0"
},
{
"fixed": "5.3.12.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezpublish-legacy/2018-11-01-1.yaml
- https://github.com/ezsystems/ezpublish-legacy
- https://web.archive.org/web/20210614172734/http://share.ez.no/community-project/security-advisories/ezsa-2018-006-xss-vulnerability-in-disabled-module-error-template
- http://share.ez.no/community-project/security-advisories/ezsa-2018-006-xss-vulnerability-in-disabled-module-error-template