XSS in doc_link
Impact
Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a pdo_ extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 4.7.8 before 4.8.1Ecosystem versions | 4.8.1 |
Version evidence: OSV · GHSA-2v82-5746-vwqc
View original version evidence (3 explicit versions)
Original source description
Impact
Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a pdo_ extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected.
Patches
Patched by 4043092, included in version 4.8.1.
Workarounds
Do both:
- Use browser supporting strict CSP.
- Enable the native PHP extensions (e.g.
mysqli) or disable displaying PHP errors (display_errors).
References
https://sourceforge.net/p/adminer/bugs-and-features/797/
For more information
If you have any questions or comments about this advisory:
- Comment at 4043092.
References
- Security advisory github.com/vrana/adminer/security/advisories/GHSA-2v82-5746-vwqc
- Security advisory nvd.nist.gov/vuln/detail/CVE-2021-29625
- Patch github.com/vrana/adminer/commit/4043092ec2c0de2258d60a99d0c5958637d051a7
- Source reference packagist.org/packages/vrana/adminer
- Source reference sourceforge.net/p/adminer/bugs-and-features/797