GHSA-2rm7-xxx8-35jhmedium6.1
MediaWiki Cross-site Scripting (XSS)
The advisory, in context
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mediawiki/core Packagist
Ecosystem versions
From 1.27.0 before 1.27.6
Fixed in 1.27.6
6 explicitly affected versions
1.27.0, 1.27.1, 1.27.2, 1.27.3, 1.27.4, 1.27.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.27.0"
},
{
"fixed": "1.27.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.27.0",
"1.27.1",
"1.27.2",
"1.27.3",
"1.27.4",
"1.27.5"
]
}mediawiki/core Packagist
Ecosystem versions
From 1.30.0 before 1.30.2
Fixed in 1.30.2
2 explicitly affected versions
1.30.0, 1.30.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.30.0"
},
{
"fixed": "1.30.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.30.0",
"1.30.1"
]
}mediawiki/core Packagist
Ecosystem versions
From 1.31.0 before 1.31.2
Fixed in 1.31.2
2 explicitly affected versions
1.31.0, 1.31.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.31.0"
},
{
"fixed": "1.31.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.31.0",
"1.31.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12471
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12471.yaml
- https://github.com/wikimedia/mediawiki
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T207603
- https://seclists.org/bugtraq/2019/Jun/12
- https://www.debian.org/security/2019/dsa-4460