GHSA-2qrr-c2gh-pr35high7.5
Wikimedia information leak vulnerability
Impact
Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mediawiki/core Packagist
| Affected range | Recorded fix |
|---|---|
| From 1.27.0 before 1.27.6Ecosystem versions | 1.27.6 |
| From 1.30.0 before 1.30.2Ecosystem versions | 1.30.2 |
| From 1.31.0 before 1.31.2Ecosystem versions | 1.31.2 |
| From 1.32.0 before 1.32.2Ecosystem versions | 1.32.2 |
Version evidence: OSV · GHSA-2qrr-c2gh-pr35
View original version evidence (12 explicit versions)
Original source description
Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2019-12474
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12474.yaml
- Source reference github.com/wikimedia/mediawiki
- Source reference lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- Source reference phabricator.wikimedia.org/T212118
- Source reference seclists.org/bugtraq/2019/Jun/12
- Security advisory www.debian.org/security/2019/dsa-4460