GHSA-2qfc-48v5-4w5hmedium6.1
SimpleSAMLphp Open redirection protection bypass
The advisory, in context
SimpleSAMLphp before 1.15.2 allows remote attackers to bypass an open redirect protection mechanism via crafted authority data in a URL.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
simplesamlphp/simplesamlphp Packagist
Ecosystem versions
Earlier releases before 1.15.2
Fixed in 1.15.2
30 explicitly affected versions
v1.12.0, v1.13.0, v1.13.0-rc1, v1.13.0-rc2, v1.13.1, v1.13.2, v1.14.0, v1.14.0-rc1, v1.14.1, v1.14.10, v1.14.11, v1.14.12, v1.14.13, v1.14.14, v1.14.15, v1.14.16, v1.14.17, v1.14.2, v1.14.3, v1.14.4, v1.14.5, v1.14.6, v1.14.7, v1.14.8, v1.14.9, v1.15.0, v1.15.0-rc1, v1.15.0-rc2, v1.15.0-rc3, v1.15.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.15.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.12.0",
"v1.13.0",
"v1.13.0-rc1",
"v1.13.0-rc2",
"v1.13.1",
"v1.13.2",
"v1.14.0",
"v1.14.0-rc1",
"v1.14.1",
"v1.14.10",
"v1.14.11",
"v1.14.12",
"v1.14.13",
"v1.14.14",
"v1.14.15",
"v1.14.16",
"v1.14.17",
"v1.14.2",
"v1.14.3",
"v1.14.4",
"v1.14.5",
"v1.14.6",
"v1.14.7",
"v1.14.8",
"v1.14.9",
"v1.15.0",
"v1.15.0-rc1",
"v1.15.0-rc2",
"v1.15.0-rc3",
"v1.15.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-6520
- https://github.com/simplesamlphp/simplesamlphp/issues/1473
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2018-6520.yaml
- https://github.com/simplesamlphp/simplesamlphp
- https://simplesamlphp.org/security/201801-02