GHSA-2ppw-6xvg-rwgwhigh7.2
GeniXCMS SQL injection vulnerability
The advisory, in context
SQL injection vulnerability in inc/lib/Control/Backend/posts.control.php in GeniXCMS 0.0.8 allows remote authenticated administrators to execute arbitrary SQL commands via the id parameter to gxadmin/index.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
genix/cms Packagist
Ecosystem versions
Earlier releases before 1.0.0
Fixed in 1.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-5346
- https://github.com/semplon/GeniXCMS/issues/61
- https://github.com/semplon/GeniXCMS/commit/abfbb6103bfa860275f89d1215ed9c3cba94791e
- https://github.com/GeniXCMS/GeniXCMS
- http://code610.blogspot.com/2017/01/genixcms-sql-injection-quick-autopsy.html
- http://www.securityfocus.com/bid/95655