GHSA-2pmx-6mm6-6v72high
Smarty arbitrary PHP code execution
The advisory, in context
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
smarty/smarty Packagist
Ecosystem versions
Earlier releases before 3.1.21
Fixed in 3.1.21
19 explicitly affected versions
v2.6.24, v2.6.25, v2.6.26, v2.6.27, v2.6.28, v2.6.29, v2.6.30, v2.6.31, v2.6.33, v3.1.11, v3.1.12, v3.1.13, v3.1.14, v3.1.15, v3.1.16, v3.1.17, v3.1.18, v3.1.19, v3.1.20
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.21"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.6.24",
"v2.6.25",
"v2.6.26",
"v2.6.27",
"v2.6.28",
"v2.6.29",
"v2.6.30",
"v2.6.31",
"v2.6.33",
"v3.1.11",
"v3.1.12",
"v3.1.13",
"v3.1.14",
"v3.1.15",
"v3.1.16",
"v3.1.17",
"v3.1.18",
"v3.1.19",
"v3.1.20"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-8350
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765920
- https://code.google.com/p/smarty-php/source/browse/trunk/distribution/change_log.txt?r=4902
- https://exchange.xforce.ibmcloud.com/vulnerabilities/97725
- https://github.com/smarty-php/smarty
- http://advisories.mageia.org/MGASA-2014-0468.html
- http://seclists.org/oss-sec/2014/q4/420
- http://seclists.org/oss-sec/2014/q4/421
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:221
- http://www.securityfocus.com/bid/70708