GHSA-2mg9-hv69-897xmedium4.3
Moodle Ability to delete glossary entries that belong to another glossary
The advisory, in context
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.7 before 3.7.1
Fixed in 3.7.1
4 explicitly affected versions
v3.7.0, v3.7.0-beta, v3.7.0-rc1, v3.7.0-rc2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7"
},
{
"fixed": "3.7.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.0-beta",
"v3.7.0-rc1",
"v3.7.0-rc2"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.6 before 3.6.5
Fixed in 3.6.5
9 explicitly affected versions
v3.6.0, v3.6.0-beta, v3.6.0-rc1, v3.6.0-rc2, v3.6.0-rc3, v3.6.1, v3.6.2, v3.6.3, v3.6.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.6"
},
{
"fixed": "3.6.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.6.0",
"v3.6.0-beta",
"v3.6.0-rc1",
"v3.6.0-rc2",
"v3.6.0-rc3",
"v3.6.1",
"v3.6.2",
"v3.6.3",
"v3.6.4"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.5 before 3.5.7
Fixed in 3.5.7
9 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6"
]
}