GHSA-2jx3-5j9v-prpphigh8.1
BlockWishList SQL Injection vulnerability
Impact
An authenticated customer can perform SQL injection
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
prestashop/blockwishlist Packagist
| Affected range | Recorded fix |
|---|---|
| From 2.0.0 before 2.1.1Ecosystem versions | 2.1.1 |
Version evidence: OSV · GHSA-2jx3-5j9v-prpp
View original version evidence (3 explicit versions)
Original source description
Impact
An authenticated customer can perform SQL injection
Patches
Issue is fixed in 2.1.1
References
- Security advisory github.com/PrestaShop/blockwishlist/security/advisories/GHSA-2jx3-5j9v-prpp
- Security advisory nvd.nist.gov/vuln/detail/CVE-2022-31101
- Patch github.com/PrestaShop/blockwishlist/commit/b3ec4b85af5fd73f74d55390b226d221298ca084
- Source reference github.com/PrestaShop/blockwishlist
- Public exploit reference packetstormsecurity.com/files/168003/Prestashop-Blockwishlist-2.1.0-SQL-Injection.html