GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-2jrw-c95w-h43ghigh7.1

Mautic has an Authorization Bypass in API v2 Endpoints

Check your stack

The advisory, in context

Summary

An authorization bypass vulnerability exists in the Mautic 7 API v2 endpoints (utilizing API Platform). Under certain conditions, roles configured with owner-scope restrictions (such as viewown or editown) are not properly enforced. This allows low-privilege authenticated API users to bypass ownership-logic controls and access or modify resources belonging to other users.

Impact

Authenticated API users with limited roles can read or modify restricted resources—including reports, contacts, and companies—that they do not own and should not have access to. This bypasses structural tenant and privilege boundaries on the platform.

Patched Versions

This security issue has been addressed in the following release:

  • 7.1.2

Note: Mautic 6.x, 5.x, and 4.x branches are not affected by this vulnerability. For general security support regarding legacy Mautic 4 releases, please refer to the ELTS page.

Workarounds

There are no official workarounds. To mitigate this issue without upgrading, temporarily revoke API credentials or narrow access permissions for any users whose roles rely on owner-scope permission containment.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

mautic/core Packagist
Ecosystem versions

From 7.0.0 before 7.1.2

Fixed in 7.1.2

6 explicitly affected versions

7.0.0, 7.0.1, 7.0.2, 7.1.0, 7.1.0-rc, 7.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "7.0.0"
        },
        {
          "fixed": "7.1.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "7.0.0",
    "7.0.1",
    "7.0.2",
    "7.1.0",
    "7.1.0-rc",
    "7.1.1"
  ]
}

References