Stored cross site scripting on saved presets
The advisory, in context
Concrete CMS (previously concrete5) before 9.2 is vulnerable to Stored XSS on Saved Presets on search.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 9.2.0
Fixed in 9.2.0
55 explicitly affected versions
8.0, 8.0.1, 8.0.2, 8.0.3, 8.1.0, 8.2.0, 8.2.0RC2, 8.2.1, 8.3.0, 8.3.1, 8.3.2, 8.4.0, 8.4.0RC3, 8.4.0RC4, 8.4.1, 8.4.2, 8.4.3, 8.4.4, 8.4.5, 8.5.0, 8.5.0RC1, 8.5.0RC2, 8.5.1, 8.5.10, 8.5.11, 8.5.12, 8.5.13, 8.5.14, 8.5.15, 8.5.16, 8.5.17, 8.5.18, 8.5.19, 8.5.2, 8.5.20, 8.5.21, 8.5.3, 8.5.4, 8.5.5, 8.5.6, 8.5.6RC1, 8.5.7, 8.5.8, 8.5.9, 9.0.0, 9.0.0RC1, 9.0.0RC3, 9.0.0RC4, 9.0.1, 9.0.2, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.2.0RC2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "9.2.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0",
"8.0.1",
"8.0.2",
"8.0.3",
"8.1.0",
"8.2.0",
"8.2.0RC2",
"8.2.1",
"8.3.0",
"8.3.1",
"8.3.2",
"8.4.0",
"8.4.0RC3",
"8.4.0RC4",
"8.4.1",
"8.4.2",
"8.4.3",
"8.4.4",
"8.4.5",
"8.5.0",
"8.5.0RC1",
"8.5.0RC2",
"8.5.1",
"8.5.10",
"8.5.11",
"8.5.12",
"8.5.13",
"8.5.14",
"8.5.15",
"8.5.16",
"8.5.17",
"8.5.18",
"8.5.19",
"8.5.2",
"8.5.20",
"8.5.21",
"8.5.3",
"8.5.4",
"8.5.5",
"8.5.6",
"8.5.6RC1",
"8.5.7",
"8.5.8",
"8.5.9",
"9.0.0",
"9.0.0RC1",
"9.0.0RC3",
"9.0.0RC4",
"9.0.1",
"9.0.2",
"9.1.0",
"9.1.1",
"9.1.2",
"9.1.3",
"9.2.0RC2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-28474
- https://concretecms.com
- https://github.com/concretecms/concretecms
- https://www.concretecms.org/about/project-news/security/2023-12-05-concrete-cms-new-cves-and-cve-updates
- https://www.concretecms.org/about/project-news/security/concrete-cms-security-advisory-2023-04-20