GHSA-2f28-69j7-85hfmedium5.7
Easy!Appointments SQL injection vulnerability
The advisory, in context
alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the order_by parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
alextselegidis/easyappointments Packagist
Ecosystem versions
Earlier releases before 1.5.2-beta.1
Fixed in 1.5.2-beta.1
23 explicitly affected versions
1.1.0, 1.1.0-beta.1, 1.1.0-beta.2, 1.1.1, 1.2.0, 1.2.0-alpha.1, 1.2.0-beta.1, 1.2.1, 1.3.0, 1.3.0-alpha.1, 1.3.0-beta.1, 1.3.0-beta.2, 1.3.1, 1.3.1-beta.1, 1.3.2, 1.3.2-beta.1, 1.4.0, 1.4.0-beta.1, 1.4.1, 1.4.2, 1.4.2-beta.1, 1.4.3, 1.4.3-beta.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.2-beta.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.1.0",
"1.1.0-beta.1",
"1.1.0-beta.2",
"1.1.1",
"1.2.0",
"1.2.0-alpha.1",
"1.2.0-beta.1",
"1.2.1",
"1.3.0",
"1.3.0-alpha.1",
"1.3.0-beta.1",
"1.3.0-beta.2",
"1.3.1",
"1.3.1-beta.1",
"1.3.2",
"1.3.2-beta.1",
"1.4.0",
"1.4.0-beta.1",
"1.4.1",
"1.4.2",
"1.4.2-beta.1",
"1.4.3",
"1.4.3-beta.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-50383
- https://github.com/alextselegidis/easyappointments/commit/0f0d71cfe0692daed9aee59bc424ce2a084fd59e
- https://easyappointments.org
- https://github.com/Abdullah4eb/CVE-2025-50383
- https://github.com/alextselegidis/easyappointments
- https://github.com/alextselegidis/easyappointments/releases/tag/1.5.2-beta.1