GHSA-2cjf-w7c4-fhf6medium6.3
Cross-site Scripting in Beanstalk console
The advisory, in context
Beanstalk console (ptrofimov/beanstalk_console) prior to 1.7.14 is vulnerable to cross-site scripting.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
ptrofimov/beanstalk_console Packagist
Ecosystem versions
Earlier releases before 1.7.14
Fixed in 1.7.14
27 explicitly affected versions
1.2.1, 1.2.2, 1.3, 1.3.1, 1.3.2, 1.4, 1.4.1, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.6, 1.6.1, 1.7, 1.7.1, 1.7.10, 1.7.11, 1.7.12, 1.7.13, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.2.1",
"1.2.2",
"1.3",
"1.3.1",
"1.3.2",
"1.4",
"1.4.1",
"1.5",
"1.5.1",
"1.5.2",
"1.5.3",
"1.6",
"1.6.1",
"1.7",
"1.7.1",
"1.7.10",
"1.7.11",
"1.7.12",
"1.7.13",
"1.7.2",
"1.7.3",
"1.7.4",
"1.7.5",
"1.7.6",
"1.7.7",
"1.7.8",
"1.7.9"
]
}