Cross-site Scripting in the yoast_seo TYPO3 extension
The advisory, in context
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 7.2.3
Fixed in 7.2.3
47 explicitly affected versions
7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.2.0, 7.2.1, 7.2.2, v1.0, v1.0-beta, v1.0-rc, v1.0.1, v1.1.0, v1.1.1, v1.1.2, v1.2.0, v1.2.1, v1.2.2, v1.2.3, v1.3.0, v1.4.0, v1.4.1, v2.0.0, v2.0.1, v2.0.2, v2.1.0, v3.0.0, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v4.0.0, v4.1.0, v5.0.0, v5.0.1, v5.1.0, v5.1.1, v6.0.0, v6.0.1, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "7.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.1.0",
"7.1.1",
"7.1.2",
"7.1.3",
"7.2.0",
"7.2.1",
"7.2.2",
"v1.0",
"v1.0-beta",
"v1.0-rc",
"v1.0.1",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.2.0",
"v1.2.1",
"v1.2.2",
"v1.2.3",
"v1.3.0",
"v1.4.0",
"v1.4.1",
"v2.0.0",
"v2.0.1",
"v2.0.2",
"v2.1.0",
"v3.0.0",
"v3.0.1",
"v3.0.2",
"v3.0.3",
"v3.0.4",
"v3.0.5",
"v4.0.0",
"v4.1.0",
"v5.0.0",
"v5.0.1",
"v5.1.0",
"v5.1.1",
"v6.0.0",
"v6.0.1",
"v7.0.0",
"v7.0.1",
"v7.0.2",
"v7.0.3",
"v7.0.4",
"v7.0.5",
"v7.0.6",
"v7.0.7"
]
}