GHSA-2853-hf2g-9843critical9.8
PHPOffice Common Improper Restriction of XML External Entity Reference
The advisory, in context
XMLReader.php in PHPOffice Common before 0.2.9 allows XXE.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpoffice/common Packagist
Ecosystem versions
Earlier releases before 0.2.9
Fixed in 0.2.9
10 explicitly affected versions
0.1, 0.1.1, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.5, 0.2.7, 0.2.8, v0.2.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.2.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1",
"0.1.1",
"0.2.0",
"0.2.1",
"0.2.2",
"0.2.3",
"0.2.5",
"0.2.7",
"0.2.8",
"v0.2.6"
]
}