GHSA-283w-xf3q-788vlow2.0
PrestaShop: Improper Use of Validation Framework
Impact
Fix improper use of validation framework
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
prestashop/prestashop Packagist
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 8.2.5Ecosystem versions | 8.2.5 |
| From 9.0.0-alpha.1 before 9.1.0Ecosystem versions | 9.1.0 |
Version evidence: OSV · GHSA-283w-xf3q-788v
View original version evidence (111 explicit versions)
Original source description
Impact
Fix improper use of validation framework
Patches
Patched in 8.2.5 and 9.1.0
Workarounds
None
References
none
References
- Security advisory github.com/PrestaShop/PrestaShop/security/advisories/GHSA-283w-xf3q-788v
- Security advisory nvd.nist.gov/vuln/detail/CVE-2026-33674
- Source reference github.com/PrestaShop/PrestaShop
- Release notes github.com/PrestaShop/PrestaShop/releases/tag/8.2.5
- Release notes github.com/PrestaShop/PrestaShop/releases/tag/9.1.0