GHSA-27qr-636m-wxg2critical10.0
codeigniter/framework SQL injection in ODBC database driver
No CVE assignedCheck your stack
The advisory, in context
CodeIgniter 3.1.0 addressed a critical security issue within the ODBC database driver. This update includes crucial fixes to mitigate a SQL injection vulnerability, preventing potential exploitation by attackers. It is noteworthy that these fixes render the query builder and escape() functions incompatible with the ODBC driver. However, the update introduces actual query binding as a more secure alternative.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
codeigniter/framework Packagist
Ecosystem versions
Earlier releases before 3.1.0
Fixed in 3.1.0
12 explicitly affected versions
3.0.0, 3.0.1, 3.0.1rc, 3.0.1rc2, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0rc, 3.0rc2, 3.0rc3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.1rc",
"3.0.1rc2",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"3.0rc",
"3.0rc2",
"3.0rc3"
]
}