GHSA-26rr-v2j2-25fhhigh
Layout XML Arbitrary Code Fix
The advisory, in context
Impact
Layout XML enabled admin users to execute arbitrary commands via block methods.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
openmage/magento-lts Packagist
Ecosystem versions
Earlier releases before 19.4.15
Fixed in 19.4.15
23 explicitly affected versions
1.9.1.1, 1.9.2.0, 1.9.2.1, 1.9.2.2, 1.9.2.3, 1.9.2.4, 1.9.3.0, 1.9.3.1, v19.4.0, v19.4.1, v19.4.10, v19.4.11, v19.4.12, v19.4.13, v19.4.14, v19.4.2, v19.4.3, v19.4.4, v19.4.5, v19.4.6, v19.4.7, v19.4.8, v19.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "19.4.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.9.1.1",
"1.9.2.0",
"1.9.2.1",
"1.9.2.2",
"1.9.2.3",
"1.9.2.4",
"1.9.3.0",
"1.9.3.1",
"v19.4.0",
"v19.4.1",
"v19.4.10",
"v19.4.11",
"v19.4.12",
"v19.4.13",
"v19.4.14",
"v19.4.2",
"v19.4.3",
"v19.4.4",
"v19.4.5",
"v19.4.6",
"v19.4.7",
"v19.4.8",
"v19.4.9"
]
}openmage/magento-lts Packagist
Ecosystem versions
From 20.0.0 before 20.0.13
Fixed in 20.0.13
12 explicitly affected versions
v20.0.0, v20.0.1, v20.0.10, v20.0.11, v20.0.12, v20.0.2, v20.0.3, v20.0.4, v20.0.5, v20.0.6, v20.0.7, v20.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "20.0.0"
},
{
"fixed": "20.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v20.0.0",
"v20.0.1",
"v20.0.10",
"v20.0.11",
"v20.0.12",
"v20.0.2",
"v20.0.3",
"v20.0.4",
"v20.0.5",
"v20.0.6",
"v20.0.7",
"v20.0.8"
]
}References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-26rr-v2j2-25fh
- https://nvd.nist.gov/vuln/detail/CVE-2021-32758
- https://github.com/OpenMage/magento-lts/commit/b99307d00b59c4a226a1e3e4083f02cf2fc8fce7
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.15
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.13