GHSA-2647-c639-qv2jcritical9.8
Server-Side Request Forgery in calibreweb
The advisory, in context
calibreweb prior to version 0.6.17 is vulnerable to server-side request forgery (SSRF). This is due to an incomplete fix for CVE-2022-0339. The blacklist does not check for 0.0.0.0, which would result in a payload of 0.0.0.0 resolving to localhost.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
calibreweb PyPI
Ecosystem versions
Earlier releases before 0.6.17
Fixed in 0.6.17
5 explicitly affected versions
0.6.12, 0.6.13, 0.6.14, 0.6.15, 0.6.16
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.6.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.6.12",
"0.6.13",
"0.6.14",
"0.6.15",
"0.6.16"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0766
- https://github.com/janeczku/calibre-web/commit/965352c8d96c9eae7a6867ff76b0db137d04b0b8
- https://github.com/janeczku/calibre-web
- https://github.com/pypa/advisory-database/tree/main/vulns/calibreweb/PYSEC-2026-304.yaml
- https://huntr.dev/bounties/7f2a5bb4-e6c7-4b6a-b8eb-face9e3add7b
- https://pypi.org/project/calibreweb