Moodle does not properly enforce MFA
The advisory, in context
A serious authentication flaw allowed attackers with valid credentials to bypass multi-factor authentication under certain conditions, potentially compromising user accounts.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 5.0.0-beta before 5.0.3
Fixed in 5.0.3
7 explicitly affected versions
v5.0.0, v5.0.0-beta, v5.0.0-rc1, v5.0.0-rc2, v5.0.0-rc3, v5.0.1, v5.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-beta"
},
{
"fixed": "5.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.0.0",
"v5.0.0-beta",
"v5.0.0-rc1",
"v5.0.0-rc2",
"v5.0.0-rc3",
"v5.0.1",
"v5.0.2"
]
}From 4.5.0-beta before 4.5.7
Fixed in 4.5.7
10 explicitly affected versions
v4.5.0, v4.5.0-beta, v4.5.0-rc1, v4.5.0-rc2, v4.5.1, v4.5.2, v4.5.3, v4.5.4, v4.5.5, v4.5.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0-beta"
},
{
"fixed": "4.5.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.5.0",
"v4.5.0-beta",
"v4.5.0-rc1",
"v4.5.0-rc2",
"v4.5.1",
"v4.5.2",
"v4.5.3",
"v4.5.4",
"v4.5.5",
"v4.5.6"
]
}From 4.4.0-beta before 4.4.11
Fixed in 4.4.11
14 explicitly affected versions
v4.4.0, v4.4.0-beta, v4.4.0-rc1, v4.4.0-rc2, v4.4.1, v4.4.10, v4.4.2, v4.4.3, v4.4.4, v4.4.5, v4.4.6, v4.4.7, v4.4.8, v4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.4.0-beta"
},
{
"fixed": "4.4.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.4.0",
"v4.4.0-beta",
"v4.4.0-rc1",
"v4.4.0-rc2",
"v4.4.1",
"v4.4.10",
"v4.4.2",
"v4.4.3",
"v4.4.4",
"v4.4.5",
"v4.4.6",
"v4.4.7",
"v4.4.8",
"v4.4.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-62398
- https://github.com/moodle/moodle/commit/67005f8b2098096f4c7ca4f78ab9ce69415d703b
- https://github.com/moodle/moodle/commit/a2078f781ae065ca1f781bd159c7615c84afcaa5
- https://access.redhat.com/security/cve/CVE-2025-62398
- https://bugzilla.redhat.com/show_bug.cgi?id=2404431
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=470387