GHSA-23fm-v895-3qxqmedium5.4
jh_captcha for Typo3 XSS Vulnerability
The advisory, in context
The jh_captcha extension through 2.1.3, and 3.x through 3.0.2, for TYPO3 allows XSS.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
haffner/jh_captcha Packagist
Ecosystem versions
From 3.0.0 before 3.0.3
Fixed in 3.0.3
3 explicitly affected versions
3.0.0, 3.0.1, 3.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.2"
]
}haffner/jh_captcha Packagist
Ecosystem versions
Earlier releases before 2.1.4
Fixed in 2.1.4
7 explicitly affected versions
1.3.0, 1.3.1, 2.0.0, 2.1.0, 2.1.1, 2.1.2, 2.1.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.3.0",
"1.3.1",
"2.0.0",
"2.1.0",
"2.1.1",
"2.1.2",
"2.1.3"
]
}