DRUPAL-CORE-2026-011
The advisory, in context
Drupal core 11.2 and above integrate the HTMX JavaScript library.
Drupal core's XSS filter does not sufficiently sanitize certain HTMX attributes, which can lead to a cross-site scripting (XSS) vulnerability.
The vulnerability is mitigated by the fact an attacker must be able to insert HTML with specific attributes.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 11.3.0 before 11.3.14
Fixed in 11.3.14
From 11.4.0 before 11.4.4
Fixed in 11.4.4
From 11.2.0 before 11.3.0
Fixed in 11.3.0
37 explicitly affected versions
11.2.0, 11.2.1, 11.2.10, 11.2.11, 11.2.12, 11.2.13, 11.2.14, 11.2.2, 11.2.3, 11.2.4, 11.2.5, 11.2.6, 11.2.7, 11.2.8, 11.2.9, 11.3.0, 11.3.0-alpha1, 11.3.0-beta1, 11.3.0-rc1, 11.3.0-rc2, 11.3.1, 11.3.10, 11.3.11, 11.3.12, 11.3.13, 11.3.2, 11.3.3, 11.3.4, 11.3.5, 11.3.6, 11.3.7, 11.3.8, 11.3.9, 11.4.0, 11.4.1, 11.4.2, 11.4.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "11.3.0"
},
{
"fixed": "11.3.14"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=11.3.0 <11.3.14"
}
},
{
"events": [
{
"introduced": "11.4.0"
},
{
"fixed": "11.4.4"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=11.4.0 <11.4.4"
}
},
{
"events": [
{
"introduced": "11.2.0"
},
{
"fixed": "11.3.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "11.2.*"
}
}
],
"versions": [
"11.2.0",
"11.2.1",
"11.2.10",
"11.2.11",
"11.2.12",
"11.2.13",
"11.2.14",
"11.2.2",
"11.2.3",
"11.2.4",
"11.2.5",
"11.2.6",
"11.2.7",
"11.2.8",
"11.2.9",
"11.3.0",
"11.3.0-alpha1",
"11.3.0-beta1",
"11.3.0-rc1",
"11.3.0-rc2",
"11.3.1",
"11.3.10",
"11.3.11",
"11.3.12",
"11.3.13",
"11.3.2",
"11.3.3",
"11.3.4",
"11.3.5",
"11.3.6",
"11.3.7",
"11.3.8",
"11.3.9",
"11.4.0",
"11.4.1",
"11.4.2",
"11.4.3"
]
}