DRUPAL-CONTRIB-2026-230unknown
DRUPAL-CONTRIB-2026-230
The advisory, in context
This module provides a user interface to select and configure icons, including a CKEditor 5 button and widget that embed an icon in formatted text.
Under uncommon situations, the CKEditor 5 widget displays admin-controlled text with appropriate filtering leading to a Cross-site scripting (XSS) vulnerability.
This vulnerability is mitigated by the fact that an attacker must have access to edit content with a text format that allows the UI Icons CKEditor 5 button.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/ui_icons Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.1.3
Fixed in 1.1.3
Ecosystem versions
From 2.0.0 before 2.0.2
Fixed in 2.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.3"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.1.3"
}
},
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.2"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.0.0 <2.0.2"
}
}
],
"versions": []
}