DRUPAL-CONTRIB-2026-219unknown
DRUPAL-CONTRIB-2026-219
The advisory, in context
Gin is an administration theme that provides a modern, clean, and customizable backend UI for editors and site administrators.
The module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability.
This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes or the administer menu permission.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/gin Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 4.1.4
Fixed in 4.1.4
Ecosystem versions
From 5.0.0 before 5.0.16
Fixed in 5.0.16
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.4"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<4.1.4"
}
},
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.0.16"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=5.0.0 <5.0.16"
}
}
],
"versions": []
}