DRUPAL-CONTRIB-2026-211unknown
DRUPAL-CONTRIB-2026-211
The advisory, in context
The module Country provides a dedicated field type for Drupal core's official country list.
The module does not sufficiently escape user input in its autocomplete widget, which can lead to a cross site scripting vulnerability.
This vulnerability is mitigated by the fact that it can not occur out of the box with the Country module, additional module(s) or custom code is required.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/country Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 2.1.3
Fixed in 2.1.3
Ecosystem versions
From 2.2.0 before 2.2.1
Fixed in 2.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.3"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<2.1.3"
}
},
{
"events": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.1"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.2.0 <2.2.1"
}
}
],
"versions": []
}