DRUPAL-CONTRIB-2026-137unknown
DRUPAL-CONTRIB-2026-137
The advisory, in context
The Feed Block module provides a block content type that displays items pulled from a remote RSS/Atom feed.
The module does not sufficiently validate or sanitize the RSS feed it generates, resulting in a stored cross-site scripting (XSS) vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/feed_block Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 2.0.2
Fixed in 2.0.2
Ecosystem versions
From 3.0.0 before 3.0.2
Fixed in 3.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.2"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<2.0.2"
}
},
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.2"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=3.0.0 <3.0.2"
}
}
],
"versions": []
}