DRUPAL-CONTRIB-2026-134
The advisory, in context
Update 2026-09-11: Increased risk score to reflect publicly documented methods for developing exploits.
This module integrates amazee.ai's AI services into Drupal, including a Postgres/pgvector vector database backend for use with Search API AI Search.
The module doesn't sufficiently sanitize filter values before using them to build SQL queries in its Postgres/pgvector backend, allowing SQL injection.
This vulnerability is mitigated by the fact that a site must be using the module's Postgres/pgvector vector database backend for a Search API AI Search index, and must expose one of that index's non-string fields as a filter (for example, through a View) that is reachable by the attacker.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.3.7
Fixed in 1.3.7
From 1.4.0 before 1.4.3
Fixed in 1.4.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.7"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.3.7"
}
},
{
"events": [
{
"introduced": "1.4.0"
},
{
"fixed": "1.4.3"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.4.0 <1.4.3"
}
}
],
"versions": []
}