DRUPAL-CONTRIB-2026-056unknown
DRUPAL-CONTRIB-2026-056
The advisory, in context
This module provides the entity type and runtime for Drupal AI Agents, enabling agents to use tools.
The module does not sufficiently check the required permissions when a tool loads content entities.
This vulnerability is mitigated by the fact that an agent must be configured to use the affected tool, and an attacker must have access to that agent.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/ai_agents Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.1.4
Fixed in 1.1.4
Ecosystem versions
From 1.2.0 before 1.2.5
Fixed in 1.2.5
Ecosystem versions
From 1.3.0 before 1.3.1
Fixed in 1.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.4"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.1.4"
}
},
{
"events": [
{
"introduced": "1.2.0"
},
{
"fixed": "1.2.5"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.2.0 <1.2.5"
}
},
{
"events": [
{
"introduced": "1.3.0"
},
{
"fixed": "1.3.1"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.3.0 <1.3.1"
}
}
],
"versions": []
}