DRUPAL-CONTRIB-2026-055
The advisory, in context
This module enables you to utilize an agent to use Drupal core actions tools with bypassed access.
Certain Drupal core actions, exposed as agent tools did not have correct access validation, and some core actions were missing associated access-level definitions.
This vulnerability is mitigated by the fact that an attacker must have access to communicate with an affected agent, the site must be configured to expose the affected tools to non-privileged users.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.2.17
Fixed in 1.2.17
From 1.3.0 before 1.3.8
Fixed in 1.3.8
From 1.4.0 before 1.4.3
Fixed in 1.4.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.17"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.2.17"
}
},
{
"events": [
{
"introduced": "1.3.0"
},
{
"fixed": "1.3.8"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.3.0 <1.3.8"
}
},
{
"events": [
{
"introduced": "1.4.0"
},
{
"fixed": "1.4.3"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.4.0 <1.4.3"
}
}
],
"versions": []
}