DRUPAL-CONTRIB-2025-119unknown
DRUPAL-CONTRIB-2025-119
The advisory, in context
This modules provides the ability to chat with an AI Agent using a large-language model (LLM) provider for different purposes.
The module doesn’t sufficiently filter LLM responses. This leads to a cross-site scripting (XSS) vulnerability where an attacker can use prompt injections on user-generated content with the LLM as context.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/ai Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.0.7
Fixed in 1.0.7
Ecosystem versions
From 1.1.0 before 1.1.7
Fixed in 1.1.7
Ecosystem versions
From 1.2.0 before 1.2.4
Fixed in 1.2.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.7"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.0.7"
}
},
{
"events": [
{
"introduced": "1.1.0"
},
{
"fixed": "1.1.7"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.1.0 <1.1.7"
}
},
{
"events": [
{
"introduced": "1.2.0"
},
{
"fixed": "1.2.4"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.2.0 <1.2.4"
}
}
],
"versions": []
}