DRUPAL-CONTRIB-2025-100unknown
DRUPAL-CONTRIB-2025-100
The advisory, in context
This module enables you to to easily create and manage faceted search interfaces.
The module doesn’t sufficiently filter certain user-provided text leading to a cross site scripting (XSS) vulnerability.
This vulnerability is mitigated by the fact that an attacker must have a role with the permission “administer facets”.
CVSS risk score (experimental) 4.8 / Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:L/SI:N/SA:N
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/facets Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 2.0.10
Fixed in 2.0.10
Ecosystem versions
From 3.0.0 before 3.0.1
Fixed in 3.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.10"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<2.0.10"
}
},
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.1"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=3.0.0 <3.0.1"
}
}
],
"versions": []
}