DRUPAL-CONTRIB-2025-034unknown
DRUPAL-CONTRIB-2025-034
The advisory, in context
The baguetteBox.js module provides integration with baguetteBox.js library.
The module doesn't sufficiently sanitize user-supplied text values leading to a cross site scripting vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/baguettebox Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 2.0.4
Fixed in 2.0.4
Ecosystem versions
From 3.0.0 before 3.0.1
Fixed in 3.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.4"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<2.0.4"
}
},
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.1"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=3.0.0 <3.0.1"
}
}
],
"versions": []
}