DRUPAL-CONTRIB-2025-031unknown
DRUPAL-CONTRIB-2025-031
The advisory, in context
This module enables you to define automations on your Drupal site.
The module doesn't sufficiently protect certain routes from CSRF attacks.
This vulnerability can be mitigated by disabling the "eca_ui" submodule, which leaves ECA functionality intact, but the vulnerable routes will no longer be available.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/eca Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.1.12
Fixed in 1.1.12
Ecosystem versions
From 2.0.0 before 2.0.16
Fixed in 2.0.16
Ecosystem versions
From 2.1.0 before 2.1.7
Fixed in 2.1.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.12"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.1.12"
}
},
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.16"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.0.0 <2.0.16"
}
},
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.7"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.1.0 <2.1.7"
}
}
],
"versions": []
}