DRUPAL-CONTRIB-2025-012unknown
DRUPAL-CONTRIB-2025-012
The advisory, in context
This module enables you to integrate the site with the Google Tag Manager (GTM) application.
The module doesn't sufficiently validate the enabling or disabling of a tag container. The routes involved are not protected against Cross Site Request Forgery (CSRF).
This vulnerability is mitigated by the fact that an attacker needs to know the machine name of the container. The machine name is a random string, making an attack more difficult.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/google_tag Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.8.0
Fixed in 1.8.0
Ecosystem versions
From 2.0.0 before 2.0.8
Fixed in 2.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.8.0"
}
},
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.8"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.0.0 <2.0.8"
}
}
],
"versions": []
}