DRUPAL-CONTRIB-2023-050
The advisory, in context
This module lets you craft and expose a GraphQL schema for Drupal 9 and 10.
The module currently does not adequately verify whether a given user has the necessary permissions to access an entity's label creating an access bypass vulnerability.
This vulnerability is mitigated by the fact that entity view and entity label access are usually handled by the same access check; developers have to opt-in for supporting different logic on entity types. Additionally your schema must make use of the EntityLabel DataProducer to be affected.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.4.0
Fixed in 3.4.0
From 4.0.0 before 4.6.0
Fixed in 4.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<3.4.0"
}
},
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.6.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=4.0.0 <4.6.0"
}
}
],
"versions": []
}