DRUPAL-CONTRIB-2023-023unknown
DRUPAL-CONTRIB-2023-023
No CVE assignedCheck your stack
The advisory, in context
This module enables you to define configurable GDPR alert messages.
The module doesn't sufficiently filter user-supplied text leading to a Cross Site Scripting (XSS) vulnerability.
This vulnerability is mitigated by the fact that an attacker needs additional permissions. The vulnerability can be exploited by an attacker with a role with the permission "administer gdpr alert" regardless of other configurations.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/gdpr_alert Packagist:https://packages.drupal.org/8
Ecosystem versions
From 1.0.0 before 1.0.1
Fixed in 1.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.0.1"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=1.0 <1.0.1"
}
}
],
"versions": []
}