DRUPAL-CONTRIB-2023-005unknown
DRUPAL-CONTRIB-2023-005
No CVE assignedCheck your stack
The advisory, in context
The Apigee Edge module allows connecting a Drupal site to Apigee X / Edge in order to build a developer portal.
Previous module versions did not support entity query level access checking, which could have led to information disclosure or access bypass in various places.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/apigee_edge Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 1.27.0
Fixed in 1.27.0
Ecosystem versions
From 2.0.0 before 2.0.8
Fixed in 2.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.27.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<1.27.0"
}
},
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.8"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=2.0.0 <2.0.8"
}
}
],
"versions": []
}