DRUPAL-CONTRIB-2021-026unknown
DRUPAL-CONTRIB-2021-026
No CVE assignedCheck your stack
The advisory, in context
The Webform module uses the CKEditor, library for WYSIWYG editing. CKEditor has released a security update that impacts Webform.
An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.
For more information, see CKEditor's announcement of the release.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/webform Packagist:https://packages.drupal.org/8
Ecosystem versions
Earlier releases before 5.28.0
Fixed in 5.28.0
Ecosystem versions
From 6.0.0 before 6.0.5
Fixed in 6.0.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.28.0"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": "<5.28.0"
}
},
{
"events": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.0.5"
}
],
"type": "ECOSYSTEM",
"database_specific": {
"constraint": ">=6.0.0 <6.0.5"
}
}
],
"versions": []
}