Integer Overflow or Wraparound in GitLab
Severity and exploitation
Assessment vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HSeverity
critical10.0CVSS measures technical severity, not the likelihood of an attack.
Known exploitation
Confirmed exploited · CISA KEV
CISA has recorded exploitation in the wild. Review its required action.
Public exploit
Exploit reference published
Source-linked evidence; not proof of attacks in the wild or independent validation.
Remediation
Source guidance available
Review the recorded instructions. Guidance may be a workaround rather than a fixed version.
What this means
GitLab CE/EE versions before 19.2.8, 19.3.5, and 19.4.2 have an integer overflow weakness. An unauthenticated user may execute arbitrary code via a crafted regular expression. Impact depends on certain conditions.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.Attack conditions
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Excerpt from the original source description below.
Review supporting sources →Affected versions
Check the exact model, release, and any platform requirements against your installation.
GitLab · GitLab
GitLab
3 ranges
GitLab · GitLab
GitLab
Compare with this publisher’s ranges. This does not inspect your installation.
affected
19.2 → before 19.2.8
semver versions
19.3 → before 19.3.5
semver versions
19.4 → before 19.4.2
semver versions
Other versions: unaffected
Product identifiers (CPE)
cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*What to do
Compare your installed product and version with the affected versions above. A matching product name alone does not confirm exposure.
Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
CISA required action ↗cve.new guidance unless attributed to a publisher. This page does not inspect your installation.
Public exploit evidence
The sources identify public exploit references. We have not independently tested them; their availability does not establish exploitation in the wild.
hackerone.com/reports/4055749 ↗Attributed to GitLabhackerone.com/reports/4058589 ↗Attributed to GitLabOriginal source description
Read the full publisher description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
References
7 sourcesView 1 more references
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-97229View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 3
Assigning organization
Additional data publisher
Additional data publisher
Timeline
All times UTCAdvisory published
Publication date supplied by the source.
Added to CISA KEV
CISA recorded known exploitation.
Source updated
Latest modification date supplied by the source.
Last imported by cve.new
Latest catalog import, not the date we first saw this advisory.
What changed
Follow changes- CVE · CVE-2026-97229
Observed 2026-10-31T00:35:11.461Z · upstream updated 2026-10-30T23:18:16.598Z
References changed
before
[ "https://gitlab.com/gitlab-org/gitlab/-/work_items/630686", "https://hackerone.com/reports/4055749", "https://hackerone.com/reports/4058589", "https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/", "https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-97229" ]
after
[ "https://gitlab.com/gitlab-org/gitlab/-/work_items/630686", "https://hackerone.com/reports/4055749", "https://hackerone.com/reports/4058589", "https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/", "https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-97229", "https://github.com/rapid7/metasploit-framework/pull/22017", "https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves/" ]
- CVE · CVE-2026-97229
Observed 2026-10-30T04:21:17.464Z · upstream updated 2026-10-30T03:55:54.495Z
Prioritization updated
before
[ { "source": "CISA-ADP", "type": "SSVC", "role": "CISA Coordinator", "timestamp": "2026-10-29T19:50:05.704572Z", "decisions": [ { "name": "Exploitation", "value": "active" }, { "name": "Automatable", "value": "yes" }, { "name": "Technical Impact", "value": "total" } ] } ]after
[ { "source": "CISA-ADP", "type": "SSVC", "role": "CISA Coordinator", "timestamp": "2026-10-13T00:00:00+00:00", "decisions": [ { "name": "Exploitation", "value": "active" }, { "name": "Automatable", "value": "yes" }, { "name": "Technical Impact", "value": "total" } ] } ]
Large field values are marked as truncated previews. Original source snapshots remain retained.
Showing up to 50 most recent observed changes.