Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-86589medium5.4

Apache Answer: User Center integration does not revoke first-login sessions after central account suspension

Impact

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

Source excerpt · apache

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

Apache Software Foundation · apache

Apache Answer

1 range

Package identity

pkg:software-id/apache.org/answer

Identity supplied by apache. Version matching requires compatible range evidence.

Compare with this publisher’s ranges. This does not inspect your installation.

affected

0 → through 2.0.2

semver versions

unaffected

unknown

Other versions: unaffected

Original source description

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Inside the record

Evidence available

Package identity
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-86589

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-303 ↗

CWE-303 Incorrect implementation of authentication algorithm

apache

Related →
Contributing organizations · 3
apache

Assigning organization

2026-10-19
CVE

Additional data publisher

2026-10-19
CISA-ADP

Additional data publisher

2026-10-30

What changed

Follow changes
No substantive changes have been recorded here yet. History starts when cve.new observes a change after tracking is enabled; earlier edits are not reconstructed.

Large field values are marked as truncated previews. Original source snapshots remain retained.

References

2 sources