API permission bypass via logic bug
Impact
In Teltonika Networks RUTOS devices running versions from 7.22 through 7.24.2 and TSWOS devices running versions 1.9 through 1.10, a vulnerability exists whereby an unauthenticated user can directly call LUA functions, bypassing validations that might be called under normal API requests. Due to those requests not following proper flows, this could lead to OS command execution.
Source excerpt · tlt_netAffected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Teltonika Networks · tlt_net
RUT
1 range
Teltonika Networks · tlt_net
RUT
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
RUT versions
Other versions: unaffected
Teltonika Networks · tlt_net
RUTX
1 range
Teltonika Networks · tlt_net
RUTX
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
RUTX versions
Other versions: unaffected
Teltonika Networks · tlt_net
RUTM
1 range
Teltonika Networks · tlt_net
RUTM
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
RUTM versions
Other versions: unaffected
Teltonika Networks · tlt_net
RUTC
1 range
Teltonika Networks · tlt_net
RUTC
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
RUTC versions
Other versions: unaffected
Teltonika Networks · tlt_net
ATRM
1 range
Teltonika Networks · tlt_net
ATRM
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
ATRM versions
Other versions: unaffected
Teltonika Networks · tlt_net
TAP
1 range
Teltonika Networks · tlt_net
TAP
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
TAP versions
Other versions: unaffected
Teltonika Networks · tlt_net
CAP
1 range
Teltonika Networks · tlt_net
CAP
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
CAP versions
Other versions: unaffected
Teltonika Networks · tlt_net
OXA
1 range
Teltonika Networks · tlt_net
OXA
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
OXA versions
Other versions: unaffected
Teltonika Networks · tlt_net
DAP
1 range
Teltonika Networks · tlt_net
DAP
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
DAP versions
Other versions: unaffected
Teltonika Networks · tlt_net
TRB
1 range
Teltonika Networks · tlt_net
TRB
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
TRB versions
Other versions: unaffected
Teltonika Networks · tlt_net
OTD
1 range
Teltonika Networks · tlt_net
OTD
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
OTD versions
Other versions: unaffected
Teltonika Networks · tlt_net
EBG
1 range
Teltonika Networks · tlt_net
EBG
Compare with this publisher’s ranges. This does not inspect your installation.
affected
7.22 → through 7.24.2
EBG versions
Other versions: unaffected
Teltonika Networks · tlt_net
SWM
1 range
Teltonika Networks · tlt_net
SWM
Compare with this publisher’s ranges. This does not inspect your installation.
affected
1.9 → through 1.10
SWM versions
Other versions: unaffected
Teltonika Networks · tlt_net
TSW
1 range
Teltonika Networks · tlt_net
TSW
Compare with this publisher’s ranges. This does not inspect your installation.
affected
1.9 → through 1.10
TSW versions
Other versions: unaffected
Original source description
In Teltonika Networks RUTOS devices running versions from 7.22 through 7.24.2 and TSWOS devices running versions 1.9 through 1.10, a vulnerability exists whereby an unauthenticated user can directly call LUA functions, bypassing validations that might be called under normal API requests. Due to those requests not following proper flows, this could lead to OS command execution.
This issue affects RUT: from 7.22 through 7.24.2; RUTX: from 7.22 through 7.24.2; RUTM: from 7.22 through 7.24.2; RUTC: from 7.22 through 7.24.2; ATRM: from 7.22 through 7.24.2; TAP: from 7.22 through 7.24.2; CAP: from 7.22 through 7.24.2; OXA: from 7.22 through 7.24.2; DAP: from 7.22 through 7.24.2; TRB: from 7.22 through 7.24.2; OTD: from 7.22 through 7.24.2; EBG: from 7.22 through 7.24.2; SWM: from 1.9 through 1.10; TSW: from 1.9 through 1.10.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-82104View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changes- CVE · CVE-2026-82104
Observed 2026-10-30T18:56:42.642Z · upstream updated 2026-10-30T16:57:57.063Z
Weakness classification changed
before
[]
after
[ { "id": "CWE-306", "description": "CWE-306 Missing Authentication for Critical Function", "source": "CISA-ADP" } ]Prioritization updated
before
[]
after
[ { "source": "CISA-ADP", "type": "SSVC", "role": "CISA Coordinator", "timestamp": "2026-10-30T16:57:34.390915Z", "decisions": [ { "name": "Exploitation", "value": "none" }, { "name": "Automatable", "value": "no" }, { "name": "Technical Impact", "value": "total" } ] } ]
Large field values are marked as truncated previews. Original source snapshots remain retained.
Showing up to 50 most recent observed changes.