OpenSearch SQL plugin: Unsafe cursor deserialization permits server code execution
Impact
OpenSearch SQL plugin versions 2.8.0.0 to 2.19.6.0 and 3.0.0.0-alpha1 to 3.7.0.0 are affected by unsafe cursor deserialization, allowing authenticated users with basic read/search permissions to trigger arbitrary code execution. The weakness is deserialization of untrusted data. This issue is fixed in releases 2.19.6.0 and 3.7.0.0.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
opensearch-project · GitHub_M
sql
2 ranges
opensearch-project · GitHub_M
sql
Compare with this publisher’s ranges. This does not inspect your installation.
affected
>= 2.8.0.0, < 2.19.6.0
>= 3.0.0.0-alpha1, < 3.7.0.0
Other versions: unknown
Original source description
OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted cursor parameter to the plugins/sql endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-63393View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 1
Assigning organization
What changed
Follow changesLarge field values are marked as truncated previews. Original source snapshots remain retained.