WordPress Profile Builder plugin <= 4.0.5 - Cross Site Scripting (XSS) vulnerability
Impact
Unauthenticated Cross Site Scripting (XSS) in Profile Builder <= 4.0.5 versions.
Source excerpt · PatchstackWhat to do
Update to 4.0.6 or a higher version.
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Cozmoslabs · Patchstack
Profile Builder
1 range
Cozmoslabs · Patchstack
Profile Builder
Compare with this publisher’s ranges. This does not inspect your installation.
affected
n/a → through 4.0.5
custom versions
From 4.0.6: unaffected
Other versions: unaffected
Original source description
Unauthenticated Cross Site Scripting (XSS) in Profile Builder <= 4.0.5 versions.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-54855View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changes- CVE · CVE-2026-54855
Observed 2026-10-30T19:16:18.956Z · upstream updated 2026-10-30T19:00:19.152Z
Prioritization updated
before
[]
after
[ { "source": "CISA-ADP", "type": "SSVC", "role": "CISA Coordinator", "timestamp": "2026-10-30T18:45:25.936842Z", "decisions": [ { "name": "Exploitation", "value": "none" }, { "name": "Automatable", "value": "no" }, { "name": "Technical Impact", "value": "partial" } ] } ]
Large field values are marked as truncated previews. Original source snapshots remain retained.
Showing up to 50 most recent observed changes.