Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-54455high7.6

OpenCATS: Authenticated SQL injection in activity DataGrid date filters

Impact

OpenCATS versions prior to 0.10.0 have an authenticated SQL injection vulnerability in activity DataGrid date filters, allowing access to sensitive database contents. An attacker with a valid login can alter the intended query. The issue is fixed in version 0.10.0.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

opencats · GitHub_M

OpenCATS

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

< 0.10.0

unaffected

unknown

Other versions: unknown

Original source description

OpenCATS is an open-source applicant tracking system and recruitment CRM for staffing agencies and hiring teams. Prior to version 0.10.0, activity DataGrid date filtering in home:CallsDataGrid and activity:ActivityDataGrid uses request-controlled period, startDate and endDate parameters without sufficient validation or escaping. The vulnerable code is in modules/home/dataGrids.php and modules/activity/dataGrids.php. The startDate and endDate values are inserted into SQL string comparisons without safe escaping, and period can directly influence generated SQL. An authenticated user with access to the affected DataGrid endpoints can alter the intended query to access sensitive database contents, including user account data, candidate records, contact details, company information, job orders and activity history. A valid OpenCATS login is required; unauthenticated exploitation is not established. This issue is fixed in version 0.10.0.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-54455

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-20 ↗

CWE-20: Improper Input Validation

GitHub_M

Related →
CWE-89 ↗

CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

GitHub_M

Related →
Contributing organizations · 2
GitHub_M

Assigning organization

2026-10-28
CISA-ADP

Additional data publisher

2026-10-29

What changed

Follow changes
  1. CVE · CVE-2026-54455

    Observed 2026-10-29T17:52:12.185Z · upstream updated 2026-10-29T17:21:29.511Z

    Prioritization updated

    before

    []

    after

    [
      {
        "source": "CISA-ADP",
        "type": "SSVC",
        "role": "CISA Coordinator",
        "timestamp": "2026-10-29T15:29:29.711483Z",
        "decisions": [
          {
            "name": "Exploitation",
            "value": "none"
          },
          {
            "name": "Automatable",
            "value": "no"
          },
          {
            "name": "Technical Impact",
            "value": "partial"
          }
        ]
      }
    ]

Large field values are marked as truncated previews. Original source snapshots remain retained.

Showing up to 50 most recent observed changes.

References

3 sources