Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-54453high7.2

OpenCATS: Authenticated Remote Code Execution via SettingsUI (manageProfessional)

Impact

OpenCATS versions prior to 0.10.0 have an authenticated vulnerability in the SettingsUI, where an administrator can input a crafted license key, potentially altering PHP syntax and causing arbitrary code execution. The attacker must have Settings module access and permission to update Professional License configuration. Successful exploitation can expose sensitive information and alter the installation.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.
Applies when

An authenticated administrator must have Settings module access and permission to update Professional License configuration, and config.php must be writable for this write-based path.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

opencats · GitHub_M

OpenCATS

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

< 0.10.0

unaffected

unknown

Other versions: unknown

Original source description

OpenCATS is an open-source applicant tracking system and recruitment CRM for staffing agencies and hiring teams. Prior to version 0.10.0, the Professional License configuration feature in SettingsUI (manageProfessional) accepts administrator-controlled license key input that is reconstructed into a PHP define() statement in config.php without safe escaping. Because the application includes config.php, crafted input can alter the file's PHP syntax and cause persistent arbitrary PHP execution with the web server process privileges. An authenticated administrator must have Settings module access and permission to update Professional License configuration, and config.php must be writable for this write-based path. Successful exploitation can read, modify or delete application data, expose candidate, contact, company, job order and user account information, alter the installation or configuration, and provide a foothold for further attacks. Unauthenticated exploitation and exploitation without Settings access are not established. This issue is fixed in version 0.10.0.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers · not supplied

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-54453

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-74 ↗

CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

GitHub_M

Related →
CWE-94 ↗

CWE-94: Improper Control of Generation of Code ('Code Injection')

GitHub_M

Related →
Contributing organizations · 1
GitHub_M

Assigning organization

2026-10-28

What changed

Follow changes
No substantive changes have been recorded here yet. History starts when cve.new observes a change after tracking is enabled; earlier edits are not reconstructed.

Large field values are marked as truncated previews. Original source snapshots remain retained.

References

4 sources