Authenticated RCE in update functionality in Guardian/CMC before 26.4.0
Impact
Nozomi Networks' Guardian and CMC products, versions before 26.4.0, have an OS command injection vulnerability in the update installation functionality. An attacker with administrative privileges can supply a crafted update bundle, allowing arbitrary commands to be executed with root privileges. This may allow the attacker to read or modify sensitive data.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.What to do
Upgrade to v26.4.0 or later.
Use internal firewall features to limit access to the web management interface.
Review all accounts with administrative privileges and delete unnecessary ones.
Install update bundles only when they come from trusted Nozomi Networks sources.
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Nozomi Networks · Nozomi
Guardian
1 range
Nozomi Networks · Nozomi
Guardian
Compare with this publisher’s ranges. This does not inspect your installation.
affected
0 → before 26.4.0
semver versions
Other versions: unaffected
Nozomi Networks · Nozomi
CMC
1 range
Nozomi Networks · Nozomi
CMC
Compare with this publisher’s ranges. This does not inspect your installation.
affected
0 → before 26.4.0
semver versions
Other versions: unaffected
Original source description
Two OS command injection vulnerabilities were discovered in the update installation functionality due to insufficient validation of the update bundle contents. An attacker with administrative privileges can remotely supply a crafted update bundle that, when installed, causes arbitrary commands to be executed with root privileges, allowing the attacker to read or modify sensitive data, change the appliance configuration, or shut down the appliance.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-33924View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Environment requirements
These conditions apply together as specified by the publisher. A matching product name alone does not establish exposure.
Nozomi · platform conditions
Any condition may hold
Any condition may hold
Vulnerable product
cpe:2.3:a:nozomi_networks:guardian:*:*:*:*:*:*:*:*From (inclusive): 0
Before: 26.4.0
Any condition may hold
Vulnerable product
cpe:2.3:a:nozomi_networks:cmc:*:*:*:*:*:*:*:*From (inclusive): 0
Before: 26.4.0
Original applicability statements
[
{
"operator": "OR",
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:nozomi_networks:guardian:*:*:*:*:*:*:*:*",
"versionStartIncluding": "0",
"versionEndExcluding": "26.4.0"
}
]
},
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:nozomi_networks:cmc:*:*:*:*:*:*:*:*",
"versionStartIncluding": "0",
"versionEndExcluding": "26.4.0"
}
]
}
]
}
]Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changesLarge field values are marked as truncated previews. Original source snapshots remain retained.