Update bundle signature bypass in Guardian/CMC before 26.4.0
Impact
A signature verification vulnerability in Nozomi Networks' Guardian and CMC products before version 26.4.0 allows an attacker with administrative privileges to supply a crafted update bundle, potentially reading or modifying sensitive data. The attacker must have administrative access. The vulnerability is due to inconsistent validation of update bundle contents.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.What to do
Upgrade to v26.4.0 or later.
Use internal firewall features to limit access to the web management interface.
Review all accounts with administrative privileges and delete unnecessary ones.
Install update bundles only when they come from trusted Nozomi Networks sources.
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Nozomi Networks · Nozomi
Guardian
1 range
Nozomi Networks · Nozomi
Guardian
Compare with this publisher’s ranges. This does not inspect your installation.
affected
0 → before 26.4.0
semver versions
Other versions: unaffected
Nozomi Networks · Nozomi
CMC
1 range
Nozomi Networks · Nozomi
CMC
Compare with this publisher’s ranges. This does not inspect your installation.
affected
0 → before 26.4.0
semver versions
Other versions: unaffected
Original source description
A signature verification vulnerability was discovered in the update installation functionality due to inconsistent validation of the update bundle contents. An attacker with administrative privileges can remotely supply a crafted update bundle that passes signature verification but runs an unsigned script when the bundle is installed. The script runs with root privileges, allowing the attacker to read or modify sensitive data, change the appliance configuration, or shut down the appliance.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-33923View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Environment requirements
These conditions apply together as specified by the publisher. A matching product name alone does not establish exposure.
Nozomi · platform conditions
Any condition may hold
Any condition may hold
Vulnerable product
cpe:2.3:a:nozomi_networks:guardian:*:*:*:*:*:*:*:*From (inclusive): 0
Before: 26.4.0
Any condition may hold
Vulnerable product
cpe:2.3:a:nozomi_networks:cmc:*:*:*:*:*:*:*:*From (inclusive): 0
Before: 26.4.0
Original applicability statements
[
{
"operator": "OR",
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:nozomi_networks:guardian:*:*:*:*:*:*:*:*",
"versionStartIncluding": "0",
"versionEndExcluding": "26.4.0"
}
]
},
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:nozomi_networks:cmc:*:*:*:*:*:*:*:*",
"versionStartIncluding": "0",
"versionEndExcluding": "26.4.0"
}
]
}
]
}
]Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changesLarge field values are marked as truncated previews. Original source snapshots remain retained.